Trunk on port-channel between Mellanox and Dell switches with VLAN 1

Posted by Pavlo Khmel on Sat 08 February 2020

Default vlan 1 does not behave as vlan 1 on mellanox. Best practice - do not use VLAN 1. But sometimes you need to use VLAN 1.

Example below will allow to have multiple VLANs between Mellanox and Dell switches with VLAN 1.

Mellanox SX1036

   interface port-channel 1
   interface ethernet 1/1 channel-group 1 mode active
   interface ethernet 1/2 channel-group 1 mode active
   interface port-channel 1 switchport mode trunk
   vlan 10
   vlan 20

Dell S6010-ON

default vlan-id 2
lacp ungroup member-independent port-channel 1

interface fortyGigE 1/1
 no ip address
 port-channel-protocol LACP 
  port-channel 1 mode active 
 no shutdown   

interface fortyGigE 1/3
 no ip address
 port-channel-protocol LACP 
  port-channel 1 mode active 
 no shutdown

interface Port-channel 1
 no ip address
 no switchport
 portmode hybrid
 switchport
 no shutdown

interface Vlan 2
!untagged fortyGigE 1/31,......
!untagged Port-channel 1

interface Vlan 1
 no ip address
 tagged Port-channel 1
 untagged TenGigabitEthernet 1/2/1-1/2/4,1/4/1-1/4/4,......
 no shutdown

interface Vlan 10
 no ip address
 tagged Port-channel 1
 no shutdown

interface Vlan 20
 no ip address
 tagged Port-channel 1
 no shutdown